
  

 
Welcome to Day 3 of the FSF/NEODAAS Workshop.  
 
Today we will look at field spectroscopy data and multispectral UAV imagery and how we 
might relate them to each other and to optical satellite imagery.  
 
The scenario: 
 
The data used for this practical was taken on the 17th September 2020 at Dryden Farm, a 
research farm owned by the University of Edinburgh: 
https://www.bing.com/maps?osid=b54d9970-65fa-40fb-889d-
35938ecc79a4&cp=55.868345~-3.153759&lvl=16&style=h&v=2&sV=2&form=S00027 
 
Multispectral imagery was taken of a barley field after harvest, when the field contained the 
cut barley stalks (brash), bare soil, weeds coming on some patches of ground and moss 
growing on wetter sections of the field. These are our end members for later classification.  
 
Reflectance spectra of each of these components were recorded using an SVC 1024i field 
spectrometer, immediately following collection of the multispectral imagery.  

 
 
The aim: 
 
The farmer would like to know the area coverage of weeds and of moss in their field, now 
that the barley has been harvested. And to know whether that is something that can be 
detected using satellites such as Sentinel 2.  
 
The objectives:  
 

• Process the field spectrometer data and produce a spectral library for the field.  

• Assess the quality of the multispectral imagery 

• Classify the image using the field spectroscopy data 

• Find a corresponding Sentinel 2 image and classify that using our field spectroscopy 
data too.  

 
 

https://www.bing.com/maps?osid=b54d9970-65fa-40fb-889d-35938ecc79a4&cp=55.868345~-3.153759&lvl=16&style=h&v=2&sV=2&form=S00027
https://www.bing.com/maps?osid=b54d9970-65fa-40fb-889d-35938ecc79a4&cp=55.868345~-3.153759&lvl=16&style=h&v=2&sV=2&form=S00027
https://fsf.nerc.ac.uk/instruments/svc_hr-1024i.shtml
https://fsf.nerc.ac.uk/instruments/svc_hr-1024i.shtml


  

Objective 1 
 
Review and process our field spectroscopy data into a spectral library.  
 

1. We will process the field spectrometer data using a Jupyter Notebook: 
Open Anaconda Prompt and switch to your “specdal” environment* by typing the 
following snippet. *If you haven’t setup this environment yet, follow the instructions 
for “FSF (Day 3 Practical” here before proceeding. 
 
conda activate specdal 

 
Then clone the tutorial from github using: 
 
git clone https://github.com/NERC-
FSF/FSF_NEODAAS_2021Workshop_FieldSpectroscopy_Practical.git 

 

2. This will create a folder in whichever directory anaconda prompt is in:

 Navigate to this folder in your computer’s file 
browser, it should be called 
“FSF_NEODAAS_2021Workshop_FieldSpectroscopy_Practical”. Each measurement 
with the field spectrometer has created a .sig file which contains the wavelength, 
corresponding irradiance, reflected radiance and reflectance measurements, as well 
as header information containing some instrument settings and metadata. These are 
contained in the “Data” folder. The SVC 1024i spectrometer also has an in build 
camera, and takes a photo for every spectra. These photos are located in the 
“Photos” folder. Have a look at these before starting the exercise to see what we 
have taken reflectance measurements of. Note that the field of view of the camera is 
not exactly the same as what the spectrometer is measuring.  

3. To start the tutorial, go back to your open anaconda prompt window and run the 
following:  

 
jupyter notebook “FSF_NEODAAS_2021Workshop_FieldSpectroscopy_Practical/Field 
Spectroscopy Notebook.ipynb” 

 
4. The rest of the instructions are in the notebook, enjoy.  

 
It is best to collect field spectra yourself, that way you have control over the conditions 
under which they are collected and you have better appreciation of the context of the 
measurements (i.e. nutrient conditions, grow period etc). However, this may not always be 
possible to do, or you may miss out recording spectra for some part of your scene. There are 
several online spectral libraries that may help in this scenario. FSF encourage the users of 
our equipment to submit field spectra and associated metadata to SPECCHIO.  
 

5. Go to http://sc22.geo.uzh.ch:8080/SPECCHIO_Web_Interface/search and see if they 
have any records of spectra that relate to your subject area. If they don’t, search for 
“birch” and press “show spectra” (SPECCHIO servers can be slow) to explore the type 
of data you can access online.  

 

https://data.neodaas.ac.uk/files/training_november_2021/docs/Computer_Setup_Instructions.pdf
http://sc22.geo.uzh.ch:8080/SPECCHIO_Web_Interface/search


  

Next we will use our spectral library to classify a multispectral orthomosaic but first we need 
to inspect our image.  
 
 
Objective 2:  
Processing UAV Multispectral Imagery. 
 
The Sensor used here is a  Sal Engineering MAIA. 9 Band Multispectral Camera matching the 
spectral response of Sentinel 2 Bands 1, 2, 3, 4, 5, 6, 7, 8 and 8a. 

 
 
It has undergone radiometric and distortion correction using software specific to this 
particular sensor, after which it was turned into an orthomosaic using the photogrammetry 
software Agisoft Metashape.  
 
As shown in the in the introductory talk, a multispectral image of a reflectance standard is 
taken before (and after) a flight. This is used to convert the digital number in your camera’s 
pixel array to surface reflectance as shown in the following picture. The image you will work 
with was converted to reflectance using a 40% reflectance panel.  

 

This is a 40% reflectance panel 
after a field season in the Arctic, 
note the marks from squashed 
mosquitoes. Panels are typically 
made of Spectralon and are good 
diffuse reflectors i.e. they reflect 
light similarly in all directions.   

https://fsf.nerc.ac.uk/instruments/MaiaS2.shtml


  

 
Figure 1 from https://doi.org/10.1139/juvs-2018-0018 Showing the factors that create a 
reflectance image.  
 
Instructions for processing multispectral imagery into an orthomosiac vary depending on 
the sensor. Micasense, a popular multispectral camera manufacturer, has good 
documentation that can be easily adapted to different sensors, here are instructions for 
Pix4D, Agisoft Metashape, OpenDroneMap (free!). For this workshop we are using ready 
processed data due to time/computing limitations for the course.  
 
What issues should we be aware of? 
 
The sensor inside multispectral cameras that capture information in visible and near infra-
red wavelengths are typically made using un-cooled silicon photodiode arrays. This means 
that they can be susceptible to drift during flight, and that their response to light may not be 
linear i.e. the digital number generated by a pixel when 500 photons of light hit it may not 
be 10 times more than the digital number generated when 50 photons of light hit it. NOTE: 

FSF can characterise the linear response of your camera in our lab, apply here. 
 
This brings a couple of practical considerations when planning your multispectral imaging 
campaign.  
 

6. Your reflectance panel should be of similar reflectance to your intended target. The 
below shows what a 99% reflectance panel looks like against a c. 10% reflectance 
background. Converting the digital numbers of this scene using this panel would be 
an extrapolation, and would assume that your camera’s sensor had a linear 
relationship between the number of photons hitting pixels at 10% and 99% 
reflectance, and the respective digital number generated. This is almost certainly 
false.  

https://doi.org/10.1139/juvs-2018-0018
https://support.micasense.com/hc/en-us/articles/115000831714-How-to-Process-MicaSense-Sensor-Data-in-Pix4D
https://support.micasense.com/hc/en-us/articles/360002693373-Process-MicaSense-sensor-data-in-Agisoft-Metashape
https://docs.opendronemap.org/multispectral.html
https://fsf.nerc.ac.uk/loans/LabForm.shtml


  

 
7. If you have a scene with a wide dynamic range of objects in it (for example snow and 

rock or sand and water), then using reflectance targets of varying, known reflectance 
(i.e. 5%, 10% and 60% reflectance) then you can use the empirical line method (from 
yesterday) to convert your image to surface reflectance. Here is a link to a tutorial on 
how to do this using ENVI.  

8. Having targets of known reflectance in your scene also gives you a way of assessing 
the quality of the reflectance orthomosaic you are working on.   
 

Lets look at our image:  
 

9. Open SNAP, navigate to and open the .dim file called “20200917_Dryden” 
10. Right click on the file in the product explorer and press “open RGB image window” 

using Bands 4, 3, 2.  
11. Under optical, you can open the “Spectrum View”. This will display the spectra of the 

pixel you hover the cursor over (note: if you can’t see anything you may need to 
right click on the graph and “Auto Range” both axes). 

12. Find and zoom in on the black, grey and white targets in the image and hover your 
cursor over them to look at their reflectance values.  

13. Open the “Field_Spec_Targets_MAIA_SRF.csv” file to see what the spectra of each 
target should look like. NOTE: FSF can measure the reflectance of your targets in our lab, apply 

here. 

QUESTION 1: WHAT PROBLEMS DO YOU SEE WITH THESE TARGETS? (ANSWERS AT 

THE END) 

 
Objective 3: 
 
Ok, lets start processing this image.  
 
 

14. Firstly we need to exclude the field borders and the UAV pilots (hi) from the image 
we want to analyse. To do this we will use the Mask Manager. Ensure the Mask 
Manager is present by View → Tool Windows → Mask Manager. In the Mask 

Manager use the  icon to make a new mask based on geometry then use the 

 polygon tool to draw a box in the main field, ensuring no bordering trees are 

https://nerc-arf-dan.pml.ac.uk/files/tutorials/nerc-fsf-airborne_practical_session.pdf
https://fsf.nerc.ac.uk/loans/LabForm.shtml


  

present. Then use the Raster → Masks → Land/Sea Mask, select all bands in the 
“processing parameters” tab and select “Use Vector as Mask”, selecting the polygon 
you just drew as the vector. Press run. The masked image will appear in the product 
explorer, you can view it using the method in #10.    

 
15. Now that we have isolated our area of interest, lets use SNAP to perform an NDVI on 

the image. NDVI is a spectral indices that uses the relatively high difference in 
reflectance between red and near infrared bands, typical of vegetation, to identify 
pixels containing vegetation. For Sentinel 2, NDVI is typically calculated using Bands 4 
(red) and 8 (NIR), but you can also use Band 8a (in the case of the MAIA sensor, this 
would be Band 9) instead of 8.   
 

16. With the masked image selected in the “product explorer”, go to Optical -> Thematic 
Land Processing -> Vegetation Radiometric Indices -> NDVI Processor in the 
Processing Parameters tab, set the source bands for Red and NIR to match that of an 
NDVI performed with Sentinel 2. In the save settings, set the directory to your 
output folder and hit run.  

17. Open the resulting NDVI image by expanding the file in the Product Explorer and 
double clicking the NDVI band. 

  
18. Healthy vegetation typically has a high NDVI (typically between 0.4 and 1). Revisit 

the Jupyter Notebook from the spectral processing practical and determine what the 
NDVI of the “vegetation” and “moss” was, comparing it to the dead vegetation 
(“brash”). Use a NDVI value between “moss” and “brash” to try to select pixels 
containing vegetation using the mask manager. In the Mask Manager press the  to 
make the expression “ ndvi > ‘your value’ “ and press OK. Pixels with a high NDVI 
should now have a red mask over them. If you have closed your Jupyter Notebook, try 0.4 as a 

value. 
19. We can calculate the area of vegetation in this image by going Raster → Masks → 

Mask Area  and selecting the mask you made using the function in #17. Note that 



  

SNAP only gives this output in km2 so you will have to multiply the number of 
masked pixels by the pixel area to get a mask area. The area of one pixel is 0.000576 
m2 or 5.76e-8 Hectares. 

20. Press  above the image pane to view your NDVI map alongside your RGB image. In 
your Navigation tab, click on the synchronise view and cursor icons as below and 
move your cursor around vegetation in your RGB image to see if it has been masked 
with your expression.  

 
 
This is good, but the farmer wanted to know the coverage of the weeds and moss, how do 
we know whether moss is being identified here, and how do we separate it from the larger 
weeds?  
 

21. We can start by uploading some spatial information from the survey. The SVC 1024i 
spectrometer has an inbuild GPS, that can work with a base station in RTK mode to 
give cm precise GPS positioning for the spectra recorded. The GPS data is saved to 
the header of each spectral file (as seen in the previous practical). To save time today 
I have grouped it into a .txt file called “Field_Spectra_Dryden”. Load this into SNAP 
as Pins using the Pin Manager (View -> Tool Windows -> Pin Manager) by pressing 
the  button and finding this .txt file. Zoom into some of the pins labelled 
“MossPatches…” and see if their corresponding pixels have been identified within 
your NDVI mask.  

 
We can narrow down our classification of vegetation in this scene by using spectral 
unmixing.  
 
Spectral unmixing is the procedure by which the measured spectrum of a mixed pixel is 
decomposed into a collection of constituent spectra, or endmembers, and a set of 
corresponding fractions, or abundances, that indicate the proportion of each endmember 
present in the pixel. - DOI: 10.1109/79.974727 
 
In our case, the end members in our scene are the soil, barley brash, vegetation and moss, 
who’s reference spectra we recorded with the field spectrometer and made into a spectral 
library in the last practical. We will now use this spectral library to perform spectral 
unmixing on our image of Dryden Farm.  
 

22. Go to Optical -> Spectral Unmixing and ensure the Source Product is set to the 
masked 20200917_Dryden multispectral image (rather than the NDVI output).  

23. Press Help -> Help and read about the algorithm SNAP uses for spectral unmixing. 
The Help section in SNAP offers good documentation on most of its functions.  



  

24. Under Endmembers, press the + icon and load the Dryden_Spectral_Lib_SNAP.csv 
file you created earlier. It should plot the spectra of your four averaged 
endmembers.  

25. For endmember fractions to be meaningful for classification, we want our unmixing 
result to give the percentage of each endmember in any one pixel. Choosing “Fully 
Constrained LSU” (Linear Spectral Unmixing) forces the model to output fractional 
abundances. Select all the bands in under “Spectral source bands:” Check your 
output folder and run the classification.  

26. Double click on the “Vegetation_abundance” band in the 
“20200917_Dryden_unmixed” file tree to open an image of Vegetation abundance. 
Pixels with a value of “1” were 100% covered in vegetation according to our model 
output, whereas a pixel with the value 0.1 has 10% coverage of vegetation. Move the 
white arrow on the colour slider to visualise how modelled vegetation distribution is 
affected by what thresholds you set.  

27. Before we determine the area of our different vegetation types, lets explore how our 
moss and vegetation classes relate to NDVI. SNAP has a scatter plot function that lets 
us explore the relationship between bands. Analysis → scatter plot. For the X-Axis 
select your NDVI layer and band and for the Y-Axis, select the Unmixed layer and 
either “Vegetation_mean_abundance” or “moss_mean_abundance” (or the 
soil/brash classes if you like).  

 
QUESTION 2: HOW WELL ARE MOSSES REPRESENTED BY NDVI IN OUR IMAGE? 

QUESTION 3: HAS THE NDVI MASK THRESHOLD VALUE (FROM #17) EXCLUDED A 

LOT OF PIXELS PICKED OUT AS “VEGETATION” BY THE UNMIXING MODEL? 

QUESTION 4: USING THE BELOW SCATTER PLOT, CAN YOU SUGGEST A GOOD VALUE 

TO USE TO CREATE A THRESHOLD FOR MASKING OUT “VEGETATION” FROM THE 

UNMIXING OUTPUT? 



  

 
28. Now use the Mask Manager to mask pixels that are “Vegetation” and “moss” 

according to the unnmixing model (decide what values to use for your threshold 
based on the colour slider or your scatter plots). Label the masks appropriately and 
change the colour of the vegetation mask to green. Zoom in again on the area where 
moss spectra were recorded (indicated by the pins in the RGB image). How well does 
our unmixing model represent our ground observations?  

29. Calculate the area of your “moss” and “vegetation” masks using Raster → Masks → 
Mask Area 

(again, multiplying the number of pixels by  0.000576 m2) 
 

QUESTION 5: HOW DOES THE AREA OF MOSS + VEGETATION COMPARE TO YOUR 

NDVI AREA?  

 
 
Objective 4:  
Another advantage of using field spectroscopy and high resolution UAV multispectral 
surveys is the ease by which you can downsample your imagery to simulate the pixel 
footprint of your satellite of interest. This is particularly useful with the MAIA camera, since 
its spectral response already replicates that of Sentinel 2.  
 

30. Downsample the “20200917_Dryden” multispectral image to 10m x 10m resolution 
by Raster -> Geometric Operations -> Resampling. In the resampling parameters tab 



  

click “By pixel resolution” and set it to 10. Choose “mean” as the downsampling 
method. Change the save file suffix from “_resampled” to “_10m” and press run.  

31. Open an RGB image of your resampled orthomosaic and see how it would look if you 
were working on an Sentinel 2 image of your site.  

32. Re-run the NDVI and Unmixing steps on your 10m resampled image, including the 
masking operations and Mask Area calculations (your pixel size is now 100m2). 

 
QUESTION 6: HOW DO THE RESAMPLED AREAS ESTIMATES COMPARE TO THE 2.5CM 

RESOLUTION IMAGERY.   
 

33. Use the  button to evenly tile your outputs so you can visually compare between 
MAIA imagery and Sentinel 2-resampled MAIA imagery. (See what this should look 
like at the end of the instructions). Has your resampled image picked up any 
vegetation in the cut part of the field?  

 
Extra credit: If you have time, and would like to explore this further, find a cloud free image 
of the field we surveyed (for the exact field click the Bing map link at the beginning of these 
instructions). Sentinel Playground is an easy way to quickly look through Sentinel 2 data 
make sure it is a close as possible to the date of the MAIA flight (17th September 2020). 
Once you have found the image, download it from scihub 
https://scihub.copernicus.eu/dhus/#/home as either a Level 2 Product, or as a Level 1 image 
and correct it to surface reflectance using ARCSI (see yesterday’s instructions). You will need 
to resample all bands to 10m in the same way we did with our MAIA image and you can run 
the spectral unmixing on the Sentinel 2 image.  
 

QUESTION 7: HOW WELL DOES THE ACTUAL SENTINEL 2 IMAGE MATCH OUR 

RESAMPLED, SIMULATED SENTINEL 2 IMAGE? 

QUESTION 8: WHAT DOES THE UNMIXING MODEL DO OVER AREAS OF 

ROAD/BUILDING ETC? WHERE MIGHT WE BE ABLE TO FIND REFERENCE SPECTRA OF 

ROADS/BUILDINGS TO EXTEND THE SCOPE OF OUR ENDMEMBERS SPECTRAL 

LIBRARY?  

 

 
  

https://apps.sentinel-hub.com/sentinel-playground/?source=S2&lat=55.86920324718219&lng=-3.148963452258613&zoom=16&preset=1-NATURAL-COLOR&layers=B01,B02,B03&maxcc=50&gain=1.0&gamma=1.0&time=2020-04-01|2020-10-01&atmFilter=&showDates=false
https://scihub.copernicus.eu/dhus/#/home


  

Answers: 
 
Question 1:  
The targets have visible wrinkles on them, this is because they are not pegged out and 
stretched properly and because of shadow, as the the solar zenith angle is low because the 
time of day (4pm) and the time of year (autumn).  
 
The reflectance of bands 1 and 2 appears to be slightly too high. Were the targets properly 
pegged out you could solve this by performing an empirical line correction, but since there 
are areas of brightness and shade on the targets, it is impossible to determine if this 
apparent high reflectance in these bands is due to angular effects from the wrinkled surface, 
or from non-linearity in sensor response from our correction using a 40% reflectance panel. 
Solution: peg your targets out properly!  
 
Question 8: The SPECCHIO online spectral library.  
 
 

 

http://sc22.geo.uzh.ch:8080/SPECCHIO_Web_Interface/search

